Powerdynamo

Das Forum für Oldtimer
Bulletin Board for vintage bikes

Moderator: Joachim

ivor
Reisschuessel-Liebhaber
Posts: 40
Joined: Wed Oct 09, 2013 10:50 pm

Powerdynamo

Postby ivor » Tue Jul 29, 2014 6:45 pm

Hello everybody, I am interested in knowing how many of you have fitted a Powerdynamo kit ? I think it may be an answer to the problems I have with the 150 sport. Getting a generator rewound is expensive, as is finding a replacement regulator unless I get a solid state one, so buying a kit that has electronic ignition, generator and regulator all inclusive seems like a good idea.
Has anyone had a bad experience with one of these ?
Many thanks, (once again !),
cheers, Tony.

rivera
Lachgastuner
Posts: 93
Joined: Mon Feb 18, 2013 1:53 pm

Re: Powerdynamo

Postby rivera » Wed Jul 30, 2014 8:18 pm

Well Tony,
I just visited the website of the Powerdynamo Company.
370,- continental Euros is the price of the whole system.!
Have you checked other sources of trouble: correct spark plug,
Carburettor settings?
In my case a brand new spark plug bought on a market directly from a
Gilera specialist had a too short thread! It didn´t even reach into the cylinder head!
Using an old one from a spare engine brought instantly a running engine! Still not perfect but a start!
The spark must have the right "heat coefficient" ( waermewert)
A friend is using this spark plug : Bosch Platin W5 AP.
Alternatively:
KLG FE 80
Bosch W225 T2
Champion N3C
Bosch W3C

Buonanotte!
Uli

ivor
Reisschuessel-Liebhaber
Posts: 40
Joined: Wed Oct 09, 2013 10:50 pm

Re: Powerdynamo

Postby ivor » Wed Jul 30, 2014 10:35 pm

Hi Uli, no, the problem is not running, the bike starts and runs just fine !
It however does not charge, and the checks I have made on both the dynamo and the regulator suggest that they are both faulty. To rewind the dynamo would probably cost nearly as much as buying the PD kit !
I just wondered if anybody here has one, and if there are any problems.
Cheers, Tony.

Kajetan2
Tank-Reserve-Benutzer
Posts: 6
Joined: Thu Mar 31, 2011 11:28 am
Location: Lindau

Re: Powerdynamo

Postby Kajetan2 » Fri Oct 03, 2014 10:17 pm

Hi Tony,

I have one installed. It works and it is not really difficult to install. I had little trouble using the right spark plug and spark plug connector as they should have less then 10kOhm.
That is all I can say, as I got the engine running this afternoon for the first time!

Kajetan

ivor
Reisschuessel-Liebhaber
Posts: 40
Joined: Wed Oct 09, 2013 10:50 pm

Re: Powerdynamo

Postby ivor » Mon Jul 13, 2015 4:39 pm

Hi, sorry it has taken so long for me to reply ! I am glad yours is working. Mine does, but not the lights, and it has cost a lot of money !


Return to “gileraclub.de-Vintage/Oldtimer”

Who is online

Users browsing this forum: No registered users and 2 guests

cron